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Chapter 6. Editing Text

This chapler contains the following information:

« Working with the Edit pull-down

= Changing cursor and keyboard modes
= Marking lexi and elemenis

= Copying and moving a marked area

= Adding emphasis to text.

Working With Text

To mark, mave, copy, delele, or emphasize lexl, you can use the Edit pull-down
[see Figure 18)
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Figure 18, Edit Pull-down

You can use: a

Cut

To put the marked area into the clipboard and remove it from the doc-
ument

Copy
To put the marked area into the clipboard without removing it from
the documant.

Pasle
To put the conlents of the clipboard inlo the document beginning at
the cursor position,

Mark an area

2 Copyright 1BM Corp. 1887

To mark a par of the document o work with

You can use:

Mark boundary
To sel the beginning and end of a marked area. This func-
tion is only useful in Free Cursor mode (See "Choosing

Keyboard Modes” on page 45).
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Mark alament
To mark one or mora aleménls
Mark lina
To mark ane or more lines.
Unmark
To remove the mark from the marked area.
Dalata

To delete the marked area from the document
Restare last deleta
To restore the last marked area you deleted 1o the cursor pasitecn.
Copy marked area
To copy the marked area io the cursor position. This funclion is only
uselul in Free Cursor mode (see “Choosing Keyboard Modes™ on
page 45).
Move marked area
To move the marked area from iis current location lo the cursor posi-
fign, This lunclion is only useful in Free Cursor mode [see "Choosing
Kayboard Modes™).
Emphasize
To insert elements thal apply highlighting to the marked area.
Get from disk
To copy all or part of anclher document or graphic or image file o
the cursor position,
Put to disk
To save the marked area (o a new document, graphic Ale, or image
file,

Choosing Cursor Modes

The way text is typed in the Document window depends on the cursor mode.
The two types of cursol modes are:

Insert
Replace.
When lhi cursor moda is Insert;
« The cursor is represenied in the Document window as a thin, vertical bar
* Typing inserts characlers al the cursor
When the cursor mode is Replace

» The cursor is represenied in the Document window as a shor, horizontal line
under Ihe curreni character

= Typing replaces the underscored character with the typed characier
The current cursor mode is displayed on the siatus line. The defaull cursor mode

whan you start NoteSmith/2 is Insert. You can press the Insen key lo change
between Inserd and Replace modes.

You can also use the user profile fo change the cursor mode, To change the
cursor mode in your user profile:

1. Select Profile from the File pull-down, then select Window contents from Uhe
Profile extended pull-down.

The Window Contenis window is displayed (see Figure 37 on page 84).
2. Change the cursor mode:
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* Select Cursor state is Insert. 1o change the cursor mode 10 Insert
« Deselect Cursor state is Insert. 10 change the cursor mode lo Replace.

3. Select OK io change the cursor mode

See Chapter 11, “Tailoring the NoleSmith/2 User Profile” on page &3, to learn
maore aboul changing your user profile.

Using the Enter, Delete, and Backspace Keys

You can use the Enter key to insert elemants or insert space within an elemant
The Enter key is designed 1o work differently within different elemonts. For
example, Il you press Enter within a Paragraph element, you creale a new Para-
graph elemenl. However, if you press Enter within an Emphasize phrase
elemant, you insert a new line within the same Emphasize phrase element. See
"Lesson 2: Typing the Letter Texi” on page 31 for an example of how the Enler
kiey works within different elements.

Yau can use the Delete and Backspace keys 1o deléte and backspace over Texl,
You can also use the Delete and Backspace keys lo remove break controls and
element lags. When you use Delete or Backspace lo remove break conirois or
element tags, NoteSmith/2 displays a prompl message 1o confirm your delelion
For more information on break controls, see "Insarting Breaks and Vartical
Space” on page 131 For more information on element tags, see "Lnder-
standing Valid Document Structure™ on page 109 and Chapler 15 "Changing
Elements” on page 127.

Choosing Keyboard Modes

The way you work with the marked area depends on the keyboard mode. The
two types of keyboard modes are:

Aulo Salect
Free Cursor.
When you work with the marked area in the Aulo Select mode you can:
= Use the Backspace and Delete keys io delete the marked area
« Type text o replace the marked area
« Move the cursor 1o unmark the marked area
« Use the marked area icon or the clipboard functions 1o move or copy the
marked area.
When you work wilh the marked area in the Free Cursor moda, you can:

» Move the cursor, delete, backspace, or iype new text in all parts of the docu-
mienl without affecting the marked area

« Make changes to the marked area only by using pull-down choices or com-
mands.

The currenl keyboard mode is displayed on the stalus line. The defaull keyboard
mode when you start HoleSmith/2 is Auto Select. To change between Freo
Cursor and Aulo Select mode, press FB,

¥ou can also change your user profile io set the keyboard mode. See
Chapter 11, “Tailoring the NoteSmith/2 User Profile” on page 83 io learn more

about changing your user profile.

Chapter 8. Editing Tast 45



I6M fnternal Uas Only

Marking Text

Once you determine the keyboard mode you want 1o use, you must mark the text
you wanl lo copy, move, delete, or emphasize. When you mark text, it is dis-
played in a different color.

Mote: You can use the profile options to select the color in which the marked
text Is displayed (see Chapter 11, "Tailoring the NoleSmith/2 User Profile” on

page 83).

You can mark text with the mouse, the keyboard, or by selecting a choice in the
Mark an area exiended pull-down from the Edit pull-down.
The lollowing example illusirales how to mark text with the mouse:

1. Create a new document called WETMARK DC wilh the general document lem-
plate [TEMPLATE OC).

You will use this documeani in lurther examples
2 With the cursor positioned in the Paragraph element, type.

In this sentence, begin the mark here, Let the mark extend
to this word here.

1. Position the mouse pointer at the beginning of the word here in the firs! sén-
lenca.

4 Press and hold down mouse buttan 1.
5 Move the mouse pointer 1o the word this in the second senlence

As you move The mouse poinier, the text afier the word here in the first sen-
tenca is marked

. Release mouse bution 1.
The area of texi you selécied is now marked.

The Tollowing example illustrales how 1o mark taxt using the keyboard.

1. With the WKTMARK.DC document open, position the cursor al the beginning of
ihe word here in the first sentance,

2 Press F9 1o anchor the mark at 1_-.hu currenl cursor position.
1. Position the cursor after the word this in the second senlence.
4 Press Shifl +F5 to mark the text fraom the mark anchor o the current cursor
position,
This example illustrates how o mark an area of text using the Mark an area
cholce in the Edit pull-down,

1, With the WKTMARK_DC document open, verify thal the keyboard mode is Free
Cursor.

The keyboard mode is displayed in the status line. Il the keyboard mode |3
Auto Select this example will nol work as described. To change the kay-
board mode to Free Cursor, press Fi.

2. Position the cursor al the baginning of the word here in the first sentence.
3 Seleci Mark an area from [he Edil pull-down.

4 Select Mark boundary from the extended pull-down 10 anchor the mark at the
current cursor position.

46  HoleSmitD isers Guite



IBM Internal Usa Only

5 Position the cursor after the word fhis in the secand senlence.

6. Select Mark an area from the Edit pull-down

7. Select Mark boundary from the Mark an area extended pull-down to mark the
lext from the anchor fo the cursor posiiion,

Mole: You can also use the Mark an area exfended pull-down 1o mark an
slement or & ling. You do not have (o be in Free Cursor mode 1o use Mark
an element or Mark a line,

Unmarking Text
You can use Unmark in (he Edit pull-down lo remove the mark from a markod
area. It iz best 1o use Unmark when you are in Free Cursor mode. When you
are in Auto Select mode, you can remove the mark by moving the cursor.

Using the Marked Area lcon to Copy Marked Text
Once text has been marked, it can be copied and inserted in another place in
the document using the marked area icon {see Figure 189)

Figure 8. Maked Area loon

To move marked text with the marked area icon:
1. Mark the area of the document you want 1o move (see “Marking Text™ on
page 46],
2 Move the mouse poinier o the marked area.

3. Press and hold down the mouse button 2. The marked area icon will appear
[see Figura 13).

4 Move the mouse poinler tosthe place in the document where you wanl io
imserl the marked arca.

Note: If the mouse pointer becomes a circle with a diagonal line in it you
cannot inserl the marked area in lhal place.

5 Lift your finger off mouse bution 2. The marked area will be inserted at the
mouke polnter,

Using the Clipboard to Copy, Cut, and Paste

While using the marked ares icon is good for copying the marked area and
inserting it in another place in the document. it is much more limited than using
the Copy, Cul, and Pasie choices from the Edit pull-down.

When yvou use Copy or Cul. you place the marked area into the clipboard, Once
the marked area is in the clipboard, you use Paste 1o insert the marked area into
any NoteSmith/2 document as many limes as you wanl, until you replace it in the
clipboard with something else.

To copy the marked area to the clipboard:
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1. Mark the area of the document you want to copy o the clipboard [ses
“Marking Text” on page 46).

2. To copy the marked area of a document lo the clipboard, select one of the
fallowing items from the Edit pull-down:

* Copy to put the marked area inlo the clipboard.
+ Cul fo put the marked area into the clipboard and remove it from the
current document.
To paste the conlents of the clipboard info a document:

1. Position the cursor at the point in the document where you wanl 1o paste the
contents of the clipboard

2 Select Paste from the Edit pull-down 1o paste Ihe contents of the clipboard 1o
the cursor position of the current documant,

The marked area you pul into the clipboard by using Copy or Cul replaces any
information that is currently in the clipboard. You can paste the information fram
the clipboard as many times as you wanl until you pul something different into

the clipboard.

The contents of the clipboard remain the same even if you open new
MoleSmith/2 documents. To copy the marked area from the current documeani
and pasie it into anolher dotumeant:

i, Mark the area of the document you want 1o copy 1o the clipboard [see
"Marking Texi" on page 48],

2 EBelect Copy from the Edit pull-down,
3. Open anolher NoteSmith/2 document or creale a now one.

4 Position the cursor in the document where you want o paste the marked
area,

5 Select Paste from the Edit pull-doswn.

Any information in the clipboard is deleted when you turn off your workstation.

Saving the Marked Area as a New Document

48

To save the marked area as a new documeank:

1. Mark the region of the document you wanl 1o save as & new document {see
“Marking Text" on page 46).

2. Select Put lo disk from the Edit pull-down,
The Put to Disk window is displayed [see Figure 20 on page 49).
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2 ASCH text
r Graphic
) bmage

Figure 20, Pul to Disk Window

You must specify

Hame

Formal

To specify the name of the new document. Refer o your oper-
ating system user's guide or check with your administrator for the
proper naming convention on your syslem. The defaull direclory
I the currenl direclory.

if you do nat want lo save the marked area in the currant direc-
tory, Ivpe the new path,

To specily the format of the new document. If you change the
formal of the marked area, you may losa lormalling Instructions

or information. You can use:
Tagged text
To store the marked area as a tagged lext document
. NoteSmith/2 uses the tags io lormat the document and
defing its structure, Tagged text is the defaull format of doc-
uments you creale using NoteSmith/2.

Do not use Tagged text if you are translerring the documaent
you creale o a different word processor. Other word
processors may nol recognize these tags. If you wani 1o
transler the document you create to a different word
processor, use RFT or ASC0 fest,

RFT
To store the marked area in an existing Rovisable-form text
(RFT) document or o convert a marked area in a tagged lexi
document or ASCH lext document 1o use with an RFT-compat-
ible application, Using RFT saves only the formatting con-
trols used by an RFT-compatible application.

If the marked area is in an RFT document, you should con-
tinue fo save it as RFT lo minimize the loss of information
thal oocurs when converting from one farmat 1o another,

ASCI text
To save the marked area in a flal fle lormal.

Use ASCI text to convert the marked area o use wilh a
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word processor or an application thal does not recognize
the formatting controds or tags used by MoleSmith/2

Graphic
To save the graphic in the marked area as an 05/2 or Pres-
entation Manager Metafile. The marked area must conlain
only one graphic, The marked area cannol conlain any
image. See Chapler 7, "Working with Graphics and
images” on page 57, lor more infarmation on working with
arfwark.

Image
To save the image in the marked area as a Text Interchange
File Formal (TIFF) file, The marked area musi contain only
one image object. The marked area cannot contain any
graphic. See Chapler 7, "Working with Graphics and
Images.” for more informalion on working with artwork.

Getting Text from Another Document

To get all of part of another document and insert il al the cursor position of the
curreni documant:

1. Position fhe cursor where you wanl 1o inser the text
2. Salect Got from disk in the Edit pull-down io copy The bext,
The Gat from Disk window is displayed (see Figure 21).
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Figure 21 Gef from Disk Window

You musl spocify:

Maima
To specify tha name of the document you wanl lo gel. Reler to
your operating system user's guide or check with your adminis-
trator for the proper AamMing convention on your syslem

If the document I8 not in the current directory or the Document
search path set in Function choices in the Profile extended pull-
down, type the new path,
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To specify the portion of the documant you want to gel. You can
specily the lollowing ranges:

Fage
To gel one or more pages from a document.

Element
To get ona or more alemenis from a document. Yiou specily
the range of elements using the identifiers of the beginning
and ending elements. The uppercase and lowercase leflers
of the element identifiers you specify must maich the identi-
fier of the elements you wan! 10 copy.

Graphic/image identifier
To gel one graphic or image In & decument by i1s identifier.
See Chapter 7, "Working with Graphics and Images” on
page 57 for more informalion on working with arfwork.

Entire document
Ta gel the entire document.

From
To specify the element identifier or graphic or image identifier
from wwhich fo start copying. You can type:
A page number
To specify The beginning page number
An elament identifier
Ta specily the beginning elamant
A graphic or image identifier
To specify ihe name of a graphic or image conlained in
a documenl.
To
To spacily the page number or element 1o end copying. You can
type:
A page number
To specily the ending page number
An element identifier
To specily the anding alemani
ASCI laxi
To get the information in a flal file format

Deleting and Restoring the Marked Area
You learned in “Using the Clipboard fo Copy, Cut, and Paste” on page 47 that
you can remove the marked area by using Cut from The Edit pull-down. If you
want 1o delete the marked area from the documant without affecting the contents
of the clipboard. you can:

« Saleci Delete from (he Edit pull-down
= Use the Delete key
= Use the Backspace key.

If you delete the marked area by selecling Delete from the Edit pull-down,
NateSmith/2 displays a prompt window fo verify that you want to delele tha
marked area. NoteSmith/2 does not display a prompt window if you delete the
marked area using the Backspace key or Delete key.
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To restore a marked area you delete by selecting Delete from the Edit pull-down,
or using the Delele kay or Backspace key, you can use Restora last delete from

the

Edit pull-down

Mole: You cannot use Restore last delete 1o restore any text you delete that i1s

ot

in @ marked area, regardiess of how you delets the text. For example, if you

delale several words in 3 senlence using the Backspace key, you cannol use
Restore last Delabe 4o restore the faxt.

The following example shows how to delete and restore a marked area:

1

2

Emphasizing Text

Wilh the WETMARK DC document open, mark any two words in the paragraph
you typed (See “Marking Text” on page 46).

Select Delete from the Edit pull-down,
NoteSmith/2 daletes thie marked area from the document.

Ta reslors the marked area you just deleted, sefec! Restore last delete from
the Edit pull-down_

MaleSmith/2 returns the marked area you deleted 1o 1S original position in
the document.

To put added emphasis on words in a document, you use the Emphasis choice in

the

Edit pull-down. You can add the following kinds of emphasis to tex in a

marked area:

Boldface phrase
Ralicized phrase
Monospaced phrase
Dversinke phrase
Subscript '
Superscript

Symbol phrase
Underiine,

in addition, you can combine several kinds of emphasis, such as Boldiace
phrase and lalicized phrase, to creale texi with Bold and ilalic emphasis.

Following is an example of how 1o emphasize text in a document:

L
i,
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Create a new document using the general document template (TEMPLATE.DC).

Position the cursor in the Paragraph element and type:
The scientific farmula for water 15 H28.

Mark the numbar 2 in the ward H20,
Salect Emphasize from the Edit pull-down.
The Emphasize window is displayed (see Figure 22 on page 53).
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[ Baldtace phrase]
[l ialicized phrase
O Monaspaced phrase
[ Derstrike phesse

[ Subscrigh

[ Superscripl

[ Symhal phrase

O Linderdine

[(ox | [concet] [tel |

Figure 22. Emphasire Window

The Emphasize window lets you assign one or more kinds of emphasis to
marked texd,

5, Select Subscript from the Emphasize window.
B. Select OK 1o change the emphasis of Ihe marked text.
The number 2 is now moved slightly below the base line of the line of text
T. Mark the word water
B, Select Emphasize from the Edit pull-down.
The Emphasize window is displayed (see Figure 22).
8. Select Italicized phrase from the Emphasize window,
10. Select OK to change the emphasis of the marked tesxt.
The word waler is now in lallcized lext
11, Mark the word waler again.
12, Salect Emphasize from the Edit pull-down.
Thi Emphasize window is displayed (ses Figure 22).
13. Select Boldface phrase from the Emphasize window.
14 Select OK to change the emphasis of the marked text.
The word waler is now in boldface and ilalicized text.

Creating Lisis

in “Browsing Through the Presentation Docurment Templale™ on page J8, you
ilearmed aboul the List element. The List elemant lefs you organize ilems of
information into a numbered or unnumbered séres. You can inser lisis using
shoricut keys, as they are defined by default key sellings.

Creating an Unordered List
The ioliowing example illusirates how io create an unordered list:

1. Create a new document using the presentation document lemplate
(TEMPLATE PDLC),

2. Position the cursor in the List ilam element.
3 Typa:
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Apples
With the cursor positioned ai the end of the word Apples, press fhe Enter
kay.
This creates a second Lisl (tem elemeni
Type:
Oranges o
With the cursor positioned at the end of the word Oranges, press the Enfer

key
This creates a third List item alemend.

Type:
Pears

. With the cursor positioned al the end of the word Pears, press the Enter key

This creaies a fourih List iiem elemanl
Pross the Enler key again,
This eliminaies the fourth List item elemani.

When you press Enler in an empty List item element, NoleSmith/2 removes
the List ifem element and ends the list, You can add new Lisl item elaments
al any time by positioning the cursor at the end of the List lem elemeant and
pressing Enler,

Creating an Ordered List

An ordared List element 1§ similar 1o an unordered List element. The dillereance
is that each List item slement in an ordersd List element has a number. Tha list

54

i\ n

umbered automatically, 50 as you add or deleie List ilem elemenis o the

beginning, middie. or end of the list. they will be renumbered correctly.

Here is an axample of creating an ordered Lis! element:

1

NoleSmitn'2 Lsars Gusde

With the document you created in the last exercise st open, position the
cursor afler the word Apple.

Type: ‘
--Hy fawvorites, in order:

. With the cursor positioned afer the colon (i), press Cird+ . [period) io inser

an ordered List element,

The cursor is positioned in the first List item element. The List ilem slement
has the numbar:

I.

List itemn appears in the stajus line.

With the cursor positioned in the first List item element, fypa:
MacIntash

. With the cursor positioned al the end of the text you typed, press Enler to

insert & new List item element

This aclion adds a new List item element, The new Lis! item elemant has
the number 2..

Each naw List item elamenl increases by one.
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B With the cursor positioned in the second List item element, type:

Golden Delicious

Each new list item you add will increase the number by one. You can also
inzert new List item elemenls between exisling list ilams.

Posaltion the cursor at the end of the word Macinfosh and press Enter 1o
insert a new List ilem slemenl.

The new List item alefmeant has the number 2. and the Golden Delicious list
itarn mow has the number 3.

With the cursor positioned in the new List item element, fype:
Granny Smith

You can add new List item elements al any time by positioning the cursor al the
end of any List item element and pressing Enter. When you add List ilem ele-
ments between existing ordered list tems, each item in the list will be renum-

bered correcily.

Chapler Summary

The importan! points to remember aboul this chapler are:

You use the Insert cursor mode o inser text at the cursor position,
You use the Replace cursor mode fo replace text al the cursor position with
lexl you type.

You use the Auto Select keyboard mode to use keys to affect the marked
area.

You use ihe Free Cursor keyboard mode fo use keys without affecting the
marked ares. -

You mark text to copy, cul, or delete il, or o save it 1o another document.

Tha text you mark can be copied or cul o the clipboard and pasled in any
NoteSmith/2 document.

You can gel text from another NoleSmith/2 document without opaning it

¥ou can restore a marked area that has been deleted with the Delete choice
or the Backspace key,

You creals ligls that are ordered or unordered.
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